I recently purchased a PMG 332AT black Bakelite telephone which I have been after for some time now. I love the look of this old phone and I wanted to restore it and have it up and running as a functional extension in my home. It was to complement the PMG switch board which has been waiting to be restored by myself for the past 10 years (more info to come).

PMG 332 AT Bakelite TelephonePMG Wooden Switchboard (PBX)

A bit of history about this phone and its origins; back in the year this phone was introduced (1939) Australia’s telegraph/telephone systems were run by the post office then called the Post Master General (PMG) until it was split off into Telecom Australia (now known as Telstra) and Australia Post in the 1975. The phones were manufactured by the British Post Office (BPO) and imported into Australia and re-badged as PMG.

The phone’s casing is constructed from Bakelite, one of the first plastics ever devised. Items which were made with Bakelite might have felt a bit cheap at the time, however now days radios and phones made from Bakelite have become collectors items, and hence if in near mint condition can be worth quite a bit of money.

One of the problems with Bakelite is that it can be very brittle, especially after aging, the phone which I managed to pick up for a decent price contains a small chip in the draw cover on the base, and a large chunk of the mouthpiece cup is missing, along with a crack down the side of the mouthpiece. I am currently hunting down replacement parts to start to restore this phone.

In the meantime I was able to open up the phone and get it functioning again. The phone’s design is fairly simple, so not too much can go wrong with them. When I first got the phone home I needed to wire a suitable modern connector to the existing cord, after plugging it in I noticed that the phone had a few issues, I could not dial out, however the phone bells would ring on an incoming call, but picking up the hand piece would not take the phone off-hook so I could not answer incoming calls either. The phone’s rotary dialler was lose in the case, however I could dial it and it would return nicely so I was confident that part was still functioning.

I opened up the phone and started to clean the contacts which contained a bit of corrosion. I tightened up all the fittings and screws to secure the rotary dialler firmly in the case, connected all the wires back into the terminal block and with some luck plugged it in and it worked! The bell would ring and I could pick up incoming calls.

Now one of the problems I face with this phone is the pulse dialling, modern phone systems use tone dialling known as DTMF (Dual-tone multi-frequency). I have read that the telephone system still supports pulse dialling, however my situation is different, I do not have a real phone line.

I am running a VoIP (Voice of Internet Protocol) system at home, the service which connects the VoIP to the PSTN (Public Switched Telephone Network) which allows me to make calls to phone numbers on the telephone network at lower rates is supplied by my ISP (Internet Service Provider). My Internet connection is ‘Naked ADSL2’, “naked” meaning its using the physical phone line for the connection, but the phone line has its connection to the telephone network “stripped” off.

Traditionally with a VoIP system, VoIP telephones are used, however a small device known as an ATA or Analogue Telephony Adapter which implements an FXS or Foreign Exchange Station (sorry about the telephone jargon) can be purchased that allows you to connect a traditional ‘analogue’ telephones to VoIP systems. I am running my own internal VoIP server on my home network. Asterisk which is an open source telephony PBX (Private Branch eXchange) software package allows me to have multiple lines in-use at the same time in either direction, I can implement voicemail, music-on-hold, extensions, and much much more.

I purchased a Grandstream HandyTone 286 (HT286) which is an ATA device and this was actually the first way I had of testing the Bakelite phone. It actually works very well although here comes the problem I was getting to earlier… it does not support pulse dialing! So I can only receive incoming calls, I can not dial out :( After doing some reading online, devices are available especially for these old phones that will convert pulse dialling into DTMF tones, so this seems like the solution to my problem.

Ok… I think that I have rambled on enough in this post so I’ll cut it short here and save the good stuff for part 2!

A few months ago I had purchased two Sony FCB-EX470L block cameras (an ebay bargain!) with the intention of playing around with machine vision, image processing, and stereo vision which would lead me into building an autonomous robot.

FCB-EX470L

I had been intending to design and build a video capture board using two NXP SAA7113‘s for video input, an FPGA, ARM9 and Ethernet, however as things like this always go time and money were lacking.

I was browsing dealextreme a few weeks ago and came across a very cheap USB 2.0 video capture device with composite, S-Video and stereo audio inputs, the device was called EasyCap. I immediately did some research (google search) on the device and found an open source Linux device driver named stk11xx which seemed like it would support it. So I ordered two of them!

Once I received the devices, first thing I did was pull them apart, I was pleasantly surprised to see that the cables came in to a connector which I had housings, crimps and a crimping tool for (Molex PicoBlade p/n: 51021-0800, Digkey p/n: WM1726-ND), so I wired up a cable direct from the camera block to the EasyCap using the S-Video C, Y and GND signals. The PCB looked like it had been manually re-worked, there was a large amount of dried up flux around some of the chips, so I cleaned it up with flux remover, this is to be expected with devices so cheap out of China.

I had quite a bit of trouble getting a picture out of the driver, first of all the latest release of the driver which at the time was 2.1.0 would not compile under my kernel (2.6.31). After reading through some forums of people in the same situation it turns out that I needed the trunk of the subversion repository, so I checked it out and compiled it, it compiled fine and loaded into the running kernel without any problems. I ran mplayer with the suitable command line switches but all I got was a blank window, I could not seem to get any picture from the device even though multiple people reported it working fine.

After a while I gave in and decided to try it under Windows. The day I was testing this I did not have the CD that came with the device, so I found some drivers on the net from a forum that explained how to get EasyCap working in Win XP SP3. I got the drivers installed and ran the application that came with it, selected NTSC-M, S-Video, enabled Preview, and it worked! A very clear 640×480 @ 25fps appeared, I was very happy with the quality of the video. So this tells me that the hardware is working fine, which is what I needed to know before proceeding with the Linux driver.

The first thing I thought could be causing the problem of it not working in Linux is that perhaps the stk11xx driver is hard-coded to only use the composite video input, so I plugged in a composite source and tried it again, It worked! It was clear what I now needed to do, I grabbed the NXP SAA7113 datasheet, looked up which registers would need changing to switch from composite video to S-Video input, there were a few combinations so without tracing the tracks on the PCB to figure out which I needed, I just changed the register values, going through modes that supported S-Video input one by one until I got it working.

I will do another post shortly with more detailed information on what is required, however if you can’t wait, all I had to do was write to the SAA7113’s Video control register to change the mode, the existing code was writing 0x80 to register 0x02, the lower 4bits set the mode, I needed to write 0x87, so I just replaced every line I could find that wrote 0x80 to register 0x02 and changed it to write 0x87 and now it is all working great from the S-Video input! I am very happy with this purchase.